using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})";
string substitution = @"""$1:$2"";""2019-05-17""";
string input = @"178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}