import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[0-9]{1,2}.)([a-zA-Z0-9\\-_\\.]+):([0-9]{1,5})";
final String string = "178.33.37.215:9999\n"
+ "213.136.87.38:8118\n"
+ "139.5.71.126:23500\n"
+ "138.201.223.250:31288";
final String subst = "\"$1:$2\";\"2019-05-17\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}