const regex = /(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[0-9]{1,2}.)([a-zA-Z0-9\\-_\\.]+):([0-9]{1,5})', 'gm')
const str = `178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288`;
const subst = `"$1:$2";"2019-05-17"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);