use strict;
my $str = '178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288';
my $regex = qr/(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/mp;
my $subst = '"$1:$2";"2019-05-17"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";