// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})").unwrap();
let string = "178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288";
let substitution = "\"$1:$2\";\"2019-05-17\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}