import Foundation
let pattern = #"(^[0-9]{1,2}.)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
178.33.37.215:9999
213.136.87.38:8118
139.5.71.126:23500
138.201.223.250:31288
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1:$2";"2019-05-17""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)