package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*Date Ordered:\s*(\d{1,2}/\d{1,2}/\d{4}).*|.*`)
var str = `Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative.
Meh Date Ordered: 4/15/1999
irrelevant
--------------Date Ordered: 4/12/3456`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}