const regex = new RegExp('.*Date Ordered:\\s*(\\d{1,2}/\\d{1,2}/\\d{4}).*|.*', 'gm')
const str = `Blah Blah Date Ordered: 5/19/2000 test is positive. Date Ordered: 4/2/2005 Additional testing negative.
Meh Date Ordered: 4/15/1999
irrelevant
--------------Date Ordered: 4/12/3456`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);