import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!-|.*-$)[A-Za-z-]{2,}$";
final String string = "abcd\n"
+ "a-b-c-d\n"
+ "-a-b-c-d\n"
+ "a-b-c-d-\n"
+ "A-B\n"
+ "a-b\n"
+ "AA\n"
+ "aa\n"
+ "a\n"
+ "A\n"
+ "AAAAAAAAAAAAAAAAAA\n"
+ "BBBBBBBBBBBBBBBBBB\n"
+ "A--A\n"
+ "b--b\n"
+ "A-------b\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}