import Foundation
let pattern = #"^(?!-|.*-$)[A-Za-z-]{2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcd
a-b-c-d
-a-b-c-d
a-b-c-d-
A-B
a-b
AA
aa
a
A
AAAAAAAAAAAAAAAAAA
BBBBBBBBBBBBBBBBBB
A--A
b--b
A-------b
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)