package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z0-9]+[\-|\.]{0,1})+[a-z0-9]@`)
var str = `xxx.sub-domena.vege.love
sub-domena.sub-do-main.dom-ain.com.pl
sub-domena.sub-do-main.dom-ain.co
sub-domena.sub-do-main.dom-ain.vege.love
vege.love
Maxi.Max@
Max-Wielk.Amiu-Max@
maxiu-maxiu-max@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}