const regex = /\$\s+(\d+)\s+(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\s+(\\d+)\\s+(\\d+)', 'gm')
const str = `\$ 3 58`;
const subst = `$1.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);