const regex = /\[(?P<tag>[A-Za-z0-9]+)\](?P<text>[А-Яа-яA-Za-z0-9- ,\.\(\)]+)(?=\[)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?P<tag>[A-Za-z0-9]+)\\](?P<text>[А-Яа-яA-Za-z0-9- ,\\.\\(\\)]+)(?=\\[)', 'gm')
const str = `[m1]Эрэн-Хото [i](городской уезд автономного района)[/i][/m1]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}