using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^\']*\'[^\']*\')*[^\']*$)";
string input = @"'E, d MMM YYY', 24, true
3, subtract(@{a.b.c}${length()},1)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}