package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(foo|bar)\d{2}`)
var str = `hello foo33 world bar12
bar66 something foo14
this one only has bar45
this one has neither`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}