re = /.*folder\.detail\\subfolder\\subfolder\\.*$/
str = 'folder.detail\\subfolder\\subfolder\\
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result