$re = '/\[\"([0-9]{28}\",\")*[0-9]{28}\"\]/m';
$str = '["1234567890123456789012345678","1234567890123456789012345679","1234567890123456789012345680"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);