import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:AT\\+CIMI|AT\\+CPIN|AT\\+QCCID|AT\\+QSIMSTAT) (?:.+) (\\d\\d)";
final String string = "6 Network Service Commands .......................................................................................................... 74\n"
+ "6.1. AT+COPS Operator Selection ............................................................................................ 74\n"
+ "6.2. AT+CREG Network Registration ........................................................................................ 76\n"
+ "6.3. AT+CSQ Signal Quality Report .......................................................................................... 78\n"
+ "6.4. AT+CPOL Preferred Operator List ...................................................................................... 79\n"
+ "6.5. AT+COPN Read Operator Names ...................................................................................... 81\n"
+ "6.6. AT+CTZU Automatic Time Zone Update ............................................................................ 81\n"
+ "6.7. AT+CTZR Time Zone Reporting ......................................................................................... 82\n"
+ "6.8. AT+QLTS Obtain the Latest Time Synchronized Through Network .................................... 84\n"
+ "6.9. AT+QNWINFO Query Network Information ........................................................................ 85\n"
+ "6.10. AT+QSPN Display the Name of Registered Network ......................................................... 87";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}