# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?>\d))\s(?=\d)/$1/gm;t' <<< "Personal Expenses $ 11 4 . 5 6"