#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+)(?<!10)\.(\d+)(?<!192\.168)(?<!172\.(1[6-9]|2\d|3[0-1]))\.(\d+)\.(\d+)"
Local $sString = "10.10.2.246" & @CRLF & _
"10.10.2.246" & @CRLF & _
"10.10.2.246" & @CRLF & _
"169.54.137.73" & @CRLF & _
"10.10.2.246" & @CRLF & _
"10.10.2.246" & @CRLF & _
"10.10.2.246" & @CRLF & _
"188.172.213.5" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")