import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)(?<!10)\\.(\\d+)(?<!192\\.168)(?<!172\\.(1[6-9]|2\\d|3[0-1]))\\.(\\d+)\\.(\\d+)";
final String string = "10.10.2.246\n"
+ "10.10.2.246\n"
+ "10.10.2.246\n"
+ "169.54.137.73\n"
+ "10.10.2.246\n"
+ "10.10.2.246\n"
+ "10.10.2.246\n"
+ "188.172.213.5\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}