const regex = /^(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])\s*[\*x]\s*(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[(\\d+|(?:\\d*\\.\\d+))(?:,\\s*(\\d+|(?:\\d*\\.\\d+)))*\\])\\s*[\\*x]\\s*(\\[(\\d+|(?:\\d*\\.\\d+))(?:,\\s*(\\d+|(?:\\d*\\.\\d+)))*\\])$', 'gm')
const str = `[0]*[1]
[2,3]*[4,5]
[6, 7, 8] * [9, 10, 11]
[12,13, 14]* [15, 16,17]
[0]x[1]
[2,3]x[4,5]
[6, 7, 8] x [9, 10, 11]
[12,13, 14]x [15, 16,17]
[1.2, 3, 4.5] x [6, 7.8, 9]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}