# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])\s*[\*x]\s*(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])$"
test_str = ("[0]*[1]\n"
"[2,3]*[4,5]\n"
"[6, 7, 8] * [9, 10, 11]\n"
"[12,13, 14]* [15, 16,17]\n"
"[0]x[1]\n"
"[2,3]x[4,5]\n"
"[6, 7, 8] x [9, 10, 11]\n"
"[12,13, 14]x [15, 16,17]\n\n"
"[1.2, 3, 4.5] x [6, 7.8, 9]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.