// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])\s*[\*x]\s*(\[(\d+|(?:\d*\.\d+))(?:,\s*(\d+|(?:\d*\.\d+)))*\])$").unwrap();
let string = "[0]*[1]
[2,3]*[4,5]
[6, 7, 8] * [9, 10, 11]
[12,13, 14]* [15, 16,17]
[0]x[1]
[2,3]x[4,5]
[6, 7, 8] x [9, 10, 11]
[12,13, 14]x [15, 16,17]
[1.2, 3, 4.5] x [6, 7.8, 9]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}