const regex = new RegExp('\\b[A-Z]_([a-zA-Z0-9])', 'g')
const str = `(X_xy09 and X_foobar or (X_abc123 and X_something))`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);