use strict;
my $str = '(X_xy09 and X_foobar or (X_abc123 and X_something))';
my $regex = qr/\b[A-Z]_([a-zA-Z0-9])/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";