$re = '/\b[A-Z]_([a-zA-Z0-9])/';
$str = '(X_xy09 and X_foobar or (X_abc123 and X_something))';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;