// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[A-Z]_([a-zA-Z0-9])").unwrap();
let string = "(X_xy09 and X_foobar or (X_abc123 and X_something))";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}