use strict;
my $str = '( class1-OID NAME \'class1\' SUP top STRUCTURAL MUST description MAY ( brand $ details $ role ) )
( class2-OID NAME \'class2\' SUP top STRUCTURAL MUST groupname MAY description )
( class3-OID NAME \'class3\' SUP top STRUCTURAL MUST ( code $ name ) )
( class4-OID NAME \'class4\' SUP top STRUCTURAL MUST ( code $ name ) MAY ( group $ description ) )
';
my $regex = qr/MUST\s+(?:\(([^()]+)\)|(\S+))\s*(?:MAY)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}