// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)MUST\s+(?:\(([^()]+)\)|(\S+))\s*(?:MAY)?").unwrap();
let string = "( class1-OID NAME 'class1' SUP top STRUCTURAL MUST description MAY ( brand $ details $ role ) )
( class2-OID NAME 'class2' SUP top STRUCTURAL MUST groupname MAY description )
( class3-OID NAME 'class3' SUP top STRUCTURAL MUST ( code $ name ) )
( class4-OID NAME 'class4' SUP top STRUCTURAL MUST ( code $ name ) MAY ( group $ description ) )
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}