$re = '/(?<strike_all> # strikethrough can be multilines
(?<!\\\\)\~{2} # Start with 2 tilde
(?!\n) # but not followed by a new line to avoid any previous tildes getting caught
(?<strike_content> # the content which excludes any tilde unless they are escaped
(?>\\\\[\~]|[^\~])*+
)
(?<!\\\\)\~{2} # terminated by 2 tildes
)/mx';
$str = '~~Hi~~ Hello, world!
~~This whole sentence is wrong~~
No ~ allowed unless it is escaped
~~Not ok unless ~ is escaped~~
~~Not ok unless \\~ is escaped~~
Another example: ~~ New
line is permitted~~
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);