import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(BradMoon-PGT-2017)\\-(\\d\\d)\\-(\\d\\d)\\_to\\_(2017)\\-(\\d\\d)\\-(\\d\\d)";
final String string = "BradMoon-PGT-2017-02-04_to_2017-02-10";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}