use strict;
my $str = 'Create new-table1 ... As select ..from table1;
Create new-table2 ... As select ..from table2;
Create new-table3 ... As select ..from table3;';
my $regex = qr/from (\w+);$/mp;
my $subst = 'from $1 where 1000 <= (select count(1) from $1);';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";