#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?'Key'[^\n][\w|\s]*)=(?'Value'[^;'"",`\n]+);?)"
Local $sString = "AccountEndpoint=https://some-base-name.documents.azure.com:443/;AccountKey=kascuh9823nfsdvxc==;" & @CRLF & _
                "Endpoint=sb://other-more-different-name.servicebus.windows.net/;SharedAccessKeyName=mysak-name;SharedAccessKey=msd8fs2bsc==;EntityPath=someentitypath;TransportType=Amqp" & @CRLF & _
                "Data Source=myServerName.whatever.local;Initial Catalog=MyDatabaseName;Persist Security Info=True;User ID=myUserId;Password=MyBadPractice;MultipleActiveResultSets=True;MultiSubnetFailover=True;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")