package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.\n]*\.([^.\n]+)\..*`)
var str = `Marketing Analyst
501.Software Engineer.MG3
Product Researcher
Managing Director
64.Legal Consultant.I44
Hardware Analyst.`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}