#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$"
Local $sString = "$100" & @CRLF & _
"240" & @CRLF & _
"234.00" & @CRLF & _
"234,092" & @CRLF & _
"250,000,000.00" & @CRLF & _
"23june23" & @CRLF & _
"08APR934"
Local $sSubst = "$"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)