$re = '/^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$/mi';
$str = '$100
240
234.00
234,092
250,000,000.00
23june23
08APR934';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;