import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(= \\(\\[interpret\\] \\s*\\(query \\(\\[i_query\\] \\(\\(name\\)([\\s\\S]*)\\)";
final String string = "(= ([interpret] \n"
+ " (query ([i_query] ((name) \n"
+ " (argument ((name item1) (eval (.Eval 0)) (.Span 0) (.Category $item12))) \n"
+ " (argument ((name item2) (eval (.Eval 1)) (.Span 1) (.Category $item24))))))))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}