const regex = /\(= \(\[interpret\] \s*\(query \(\[i_query\] \(\(name\)([\s\S]*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(= \\(\\[interpret\\] \\s*\\(query \\(\\[i_query\\] \\(\\(name\\)([\\s\\S]*)\\)', 'gm')
const str = `(= ([interpret]
(query ([i_query] ((name)
(argument ((name item1) (eval (.Eval 0)) (.Span 0) (.Category \$item12)))
(argument ((name item2) (eval (.Eval 1)) (.Span 1) (.Category \$item24))))))))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}