use strict;
my $str = '(= ([interpret]
(query ([i_query] ((name)
(argument ((name item1) (eval (.Eval 0)) (.Span 0) (.Category $item12)))
(argument ((name item2) (eval (.Eval 1)) (.Span 1) (.Category $item24))))))))';
my $regex = qr/\(= \(\[interpret\] \s*\(query \(\[i_query\] \(\(name\)([\s\S]*)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}