using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(o(?1)?o)\b";
string input = @"o 1
oo 2
ooo 3
oooo 4
ooooo 5
oooooo 6
ooooooo 7
oooooooo 8
ooooooooo 9
oooooooooo 10
ooooooooooo 11
oooooooooooo 12
ooooooooooooo 13
oooooooooooooo 14
ooooooooooooooo 15
oooooooooooooooo 16
ooooooooooooooooo 17
oooooooooooooooooo 18
ooooooooooooooooooo 19
oooooooooooooooooooo 20
ooooooooooooooooooooo 21
oooooooooooooooooooooo 22
ooooooooooooooooooooooo 23
oooooooooooooooooooooooo 24
ooooooooooooooooooooooooo 25
oooooooooooooooooooooooooo 26
ooooooooooooooooooooooooooo 27
oooooooooooooooooooooooooooo 28
ooooooooooooooooooooooooooooo 29
oooooooooooooooooooooooooooooo 30
ooooooooooooooooooooooooooooooo 31
oooooooooooooooooooooooooooooooo 32
ooooooooooooooooooooooooooooooooo 33
oooooooooooooooooooooooooooooooooo 34
ooooooooooooooooooooooooooooooooooo 35
oooooooooooooooooooooooooooooooooooo 36
ooooooooooooooooooooooooooooooooooooo 37
oooooooooooooooooooooooooooooooooooooo 38
ooooooooooooooooooooooooooooooooooooooo 39
oooooooooooooooooooooooooooooooooooooooo 40
ooooooooooooooooooooooooooooooooooooooooo 41
oooooooooooooooooooooooooooooooooooooooooo 42
ooooooooooooooooooooooooooooooooooooooooooo 43
oooooooooooooooooooooooooooooooooooooooooooo 44
ooooooooooooooooooooooooooooooooooooooooooooo 45
oooooooooooooooooooooooooooooooooooooooooooooo 46
ooooooooooooooooooooooooooooooooooooooooooooooo 47
oooooooooooooooooooooooooooooooooooooooooooooooo 48
ooooooooooooooooooooooooooooooooooooooooooooooooo 49
oooooooooooooooooooooooooooooooooooooooooooooooooo 50
ooooooooooooooooooooooooooooooooooooooooooooooooooo 51
oooooooooooooooooooooooooooooooooooooooooooooooooooo 52
ooooooooooooooooooooooooooooooooooooooooooooooooooooo 53
oooooooooooooooooooooooooooooooooooooooooooooooooooooo 54
ooooooooooooooooooooooooooooooooooooooooooooooooooooooo 55
oooooooooooooooooooooooooooooooooooooooooooooooooooooooo 56
ooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 57
oooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 58
ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 59
oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 60
ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 61
oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 62
ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 63
oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 64
ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo 65";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}