use strict;
my $str = '1. Q Legionella species kve/liter W57209
analysis conform, confirmation e.g. NEN-EN-ISO
11731 using MALDI-Tof MS
<100 < 100 < 100 < 100
ties 22
2. Monstervolume ml
.Activitie
4. Assessment of AIDS, drinking water decision
norm 100 kve/litre
compliant compliant compliant
Order code
MonsterCode
Matrix
Customer code
Sample point description
Sampling date
Date of receipt';
my $regex = qr/(?<=Tof MS\n).....................[0-9]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}