#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\+|00)?968)?[279]\d{7}$"
Local $sString = "22345678" & @CRLF & _
"72345678" & @CRLF & _
"92345678" & @CRLF & _
"+96822345678" & @CRLF & _
"0096822345678" & @CRLF & _
"96822345678" & @CRLF & _
"+96872345678" & @CRLF & _
"0096872345678" & @CRLF & _
"96827345678" & @CRLF & _
"+96829345678" & @CRLF & _
"0096892345678" & @CRLF & _
"96892345678" & @CRLF & _
"" & @CRLF & _
"12345678" & @CRLF & _
"+96812345678" & @CRLF & _
"0096812345678" & @CRLF & _
"96812345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")