use strict;
my $str = 'com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD, THE]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=, clientId=12345]
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H]
name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345
name=User1, clientName=HARVARD LAW SCHOOL, THE
com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=H, clientId=12345]
name=User1, clientName=, clientId=12345
name=User1, clientName=H';
my $regex = qr/\bclientName=([^\r\n,=]+(?:,(?!\h*\w+=)[^\r\n,=]*)*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";