use strict;
my $str = 'text abcd text text efgh';
my $regex = qr~(.*)text~sup;
my $subst = '${1}bar';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";