# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=(?:\d{3})+(?!\d|\.\d))/,/gm;t' <<< "123456789123456789123456789
123456789
12345678
12345678.11"