$re = '/(?<=\d)(?=(?:\d{3})+(?!\d|\.\d))/m';
$str = '123456789123456789123456789
123456789
12345678
12345678.11';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;