using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<left>\{.*(?P<buffer_declaration>char\s+(?P<buffer_name>\w+)\[(?P<buffer_size>\d+)]\s*;).*?)(?P<insert_place>\s)(?P<right>(?P<printing_buffer>\w*pr\w*\(\s*\"".*?\""[^)]*?(?P=buffer_name).*\)\s*;).*})";
string input = @"{
char buffer[10];
FILE *file = fopen(""input.txt"", ""r"");
if (file) {
fread(buffer, 1, 10, file);
fclose(file);
}
printf(""%s\n"", buffer);
return 0;
}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}