package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?P<left>\{.*(?P<buffer_declaration>char\s+(?P<buffer_name>\w+)\[(?P<buffer_size>\d+)]\s*;).*?)(?P<insert_place>\s)(?P<right>(?P<printing_buffer>\w*pr\w*\(\s*\".*?\"[^)]*?(?P=buffer_name).*\)\s*;).*})`)
var str = `{
char buffer[10];
FILE *file = fopen("input.txt", "r");
if (file) {
fread(buffer, 1, 10, file);
fclose(file);
}
printf("%s\n", buffer);
return 0;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}