# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<[^>]+>(*SKIP)(*FAIL)|\b([\pL'’-]{2,})(?![\d\pL])"
test_str = ("\n"
"<div>The regex selects words of at least 2 characters. If you want to increase this number, change the minimum number here: {2,}, in the regex.</div>\n\n"
"<div>The regex matches compound words and words containing a single quote. Eg: don't, dust-filled.</div>\n"
"<div>It does not select punctuations or inside tags.</div>\n\n"
"<div>If you don't want to select compound words, remove the dash at the end of [\\pL'’-] in the regex.</div>\n\n"
"<div>It does not select words containing digits: 123start, start123, sta123rt.</div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.